【poj1961\kmp算法next数组思想】Period

http://poj.org/problem?id=1961

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 20690 Accepted: 10091

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意是让输出前i长每一段的最小循环节的循环数(定语有点多),先假设k是一个循环节,

  • 那么k肯定满足:(充分必要,证明参考lyd书上P70)
  • k能整除i
  • k是i的候选项
  • i-k也是i的候选项

那实际上就是kmp找next数组。

 


#include<algorithm>
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1e6+23;
char s[maxn];
int n;
int nxt[maxn]={0};
int main()
{
    int cnt=1;
    while(1)
    {
        scanf("%d",&n);
        if(n==0) return 0;
        printf("Test case #%d\n",cnt++);
        memset(nxt,0,sizeof(int)*(n+11));
        scanf("%s",s+1);
        for(int i=2,j=0;i<=n;i++)
        {
            while(j>0&&s[i]!=s[j+1]) j=nxt[j];
            if(s[i]==s[j+1]) j++;
            nxt[i]=j;
        }
        for(int i=2;i<=n;i++)
        {
            if(nxt[i])
            {
                if(!(i%(i-nxt[i])))
                {
                    printf("%d %d\n",i,i/(i-nxt[i]));
                }
            }
        }
        printf("\n");
    }
    
}

 

发表评论

邮箱地址不会被公开。 必填项已用*标注