【对顶堆】Running Median POJ – 3784
Running Median
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3467 Accepted: 1606
Description
For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
Output
For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.
Sample Input
3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56
Sample Output
1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3
题意就是找每个奇数之前的中位数。
用对顶堆可以实现在线算法。
对顶堆思想是两个堆,可以用优先队列实现,一个大根堆一个小根堆,分别装一半元素,他们交接的地方就是答案。
本题用大根堆装小于中位数的元素(1~M/2),小根堆装大于中位数的元素(M/2+1~M)。元素个数保持相对平衡,只要有一个堆不符合要求就从另一个堆里面拿元素补或者补到另一个堆。这样小根堆的堆顶永远是M/2+1大的元素,也就是中位数。
- 坑:
- STL容器priority_queue的size()函数返回的是unsigned long long类型,如果你想小减去大,就会炸掉…….
//#include<bits/stdc++.h>
#include<vector>
#include<queue>
#include<stdio.h>
#include<iostream>
using namespace std;
priority_queue<int,vector<int> ,greater<int> > qs;
priority_queue<int> qb;
int p,m,idx;
int main()
{
scanf("%d",&p);
while(p--)
{
int sta=1;
while(!qs.empty()) qs.pop();
while(!qb.empty()) qb.pop();
scanf("%d%d",&idx,&m);
printf("%d %d\n",idx,m/2+1);
int midn=0;
scanf("%d",&midn);
qs.push(midn);
printf("%d%c",midn," \n"[1==m]);
for(int i=2;i<=m;i++)
{
int k;
scanf("%d",&k);
if(k>=midn)
{
qs.push(k);
}
else
{
qb.push(k);
}
if(((int)qs.size()-(int)qb.size())>1)
{
int tmp=qs.top();
qb.push(tmp);
qs.pop();
}
else if(qb.size()>qs.size())
{
int tmp=qb.top();
qs.push(tmp);
qb.pop();
}
if(i&1)
{
sta++;
printf("%d%c",qs.top()," \n"[i==m||sta%10==0]);
midn=qs.top();
}
}
}
}
发表评论