【组合数学】J – Rooks LightOJ – 1005

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.



Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.

Input
Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output
For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input
8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output
Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0

要求在n*n的格子里摆放k个物品,使得每行每列只有一个物品。问有几种方法。

每行只有一个物品的摆放方法是[latex]A(n,k)[/latex],当行确定的时候实际上列的顺序已经确定,只需要让他们不相互冲突就可以了所以是[latex]C(n,k)[/latex]种方法。把他们乘起来就可以了。

有个坑点,当k取0个物品的时候视为有一种方法,我因为这个WA了几发

#include<bits/stdc++.h>
using namespace std;

typedef long long ll;
ll c[35][35]={0};
ll ca(ll n,ll k)
{
	
	ll res1=1,res2=1;
	for(ll i=0;i<k;i++)
	{
		res1*=(n-i);
	}
	return res1;
}
int main()
{
	ll t,n,k;
	for(int i=0;i<=30;i++) c[i][0]=1;
	for(int i=1;i<=30;i++)
	{
		for(int j=1;j<=i;j++)
		{
			c[i][j]=c[i-1][j-1]+c[i-1][j];
		 } 
	}
	scanf("%lld",&t);
	for(ll i=1;i<=t;i++)
	{
		scanf("%lld%lld",&n,&k);
		printf("Case %lld: ",i);
		if(k>n)
		{
			printf("0\n");
			continue;
		}
		printf("%lld\n",ca(n,k)*c[n][k]);
	}	
} 

 

发表评论

邮箱地址不会被公开。 必填项已用*标注