LightOJ – 1045 K进制的位数

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input
Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output
For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input
5

5 10

8 10

22 3

1000000 2

0 100

Sample Output
Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1
  • n!=base^m
  • m=log_base(n!)
  • m就是位数。预处理出n!的log值。
  • 还有一种方法:斯特林公式
#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;
int t,n,b;
const int MAXN=1e6+233;
double fac[MAXN];
int main()
{
	fac[0]=0;
	scanf("%d",&t);
	for(int i=1;i<MAXN-23;i++)
	{
		fac[i]=fac[i-1]+log10(1.0*i);
	}
	for(int i=1;i<=t;i++)
	{
		scanf("%d%d",&n,&b);
		int ans=1;
		if(n!=0) 
		ans=ceil(fac[n]/log10(1.0*b));
		printf("Case %d: %d\n",i,ans);
	}
}

 

发表评论

邮箱地址不会被公开。 必填项已用*标注